FC2ブログ


全件表示TopRSSAdmin
はじめてのcatalyst
2005 / 07 / 07 ( Thu )

・管理VLAN(VLAN1)にIPアドレスを付与する(telnetで操作できるようになる)
switch(config)# line vty 0 4
switch(config-line)# password cisco
switch(config-line)# exit
switch(config)# interface vlan 1
switch(config-if)# ip address 192.168.1.1 255.255.255.0
switch(config-if)# no shutdown

・学習済みのMACアドレス一覧
switch# show mac-address-table

・エージングタイムの確認
switch# show mac address-table aging-time

・MACアドレスをテーブルに追加(例)vlan1の8番ポート先にMACアドレスff-dd-cc-ee-aa-bbがあるとして。
switch(config)# mac-address-table static ffdd.ccee.aabb vlan 1 interfase f0/8

・ポートセキュリティ設定
switch(config)# interface f0/8
⇒ポートセキュリティを設定するインターフェースモードに入る。

switch(config-if)# switchport mode access
⇒ポートセキュリティを設定する端末がPCの場合(vlanを2つ以上組んでいない場合有効)

switch(config-if)# switchport port-security
⇒ポートセキュリティモードON

switch(config-if)# switchport port-security violation shutdown
⇒ポートセキュリティに引っかかった場合の対応(違反した場合シャットダウンする)

switch(config-if)# switchport port-security mac-address [MACアドレス]
⇒許可するMACアドレスを登録

・VLAN
switch(config-if)#switchport mode access
※1port1VLANに対応
switch(config-if)#switchport access vlan [VLAN番号]

特権モードから次のコマンドでvlanモードに移行
switch# vlan database
⇒vlanモードに移行する

switch(vlan)#vlan [vlan番号] name [VLAN名]
⇒VLANに名前をつける。

switch#delete flash:vlan.dat
⇒特権モードからVLAN設定を消去する。(VLAN設定はコピーコマンドを使用しなくても自動的にFLASHに書き込まれる)

※通常はvlan databaseからvlanコマンドで名前をつけてからvlanを作成する方がよい。

■VLANトランク接続
VLANタグ
・ISL(Inter-Switch Link)CISCOオリジナル
⇒フレーム全体をカプセル化する
・IEEE802.1Q
⇒イーサネットのヘッダとIPヘッダの間に4バイトのタグが挿入される。

switch(config-if)#switchport mode trunk
⇒対向がaccessでなければトランク

switch(config-if)#switchport mode dynamic auto
⇒対向のポートがtrunkまたはdesirableならトランク

switch(config-if)#switchport mode dynamic desirable
⇒対向のポートがautoまたはtrunk、desirableならトランク

switch(config-if)#switchport trunk encapsulation {dot1q | isl}
⇒2950はこのコマンドが必要

switch(config-if)#switchport trunk allowed vlan vlanリスト
⇒トランクのトラフィック制限

■トランクルーティング
VLANタグを識別させるためにサブインターフェース(1つの物理インターフェースに複数の論理アドレスを使用できる)を利用する。

・サブインターフェース
例) interface FastEthernet0/0.10

encapsulation {dot1q | isl} VLAN-ID
⇒カプセス化タイプと対応するVLANを設定する。

IPアドレスはサブインターフェースにつける。



11 : 59 : 45 | トラックバック(0) | コメント(0) | page top↑
<<TTLのはなし | ホーム | RedHat環境下でJavaを使ってグラフィックを表示させるときに使ったコマンド>>
コメント
コメントの投稿














管理者にだけ表示を許可する

トラックバック
トラックバックURL
http://redhatman.jp/tb.php/49-b4098103
この記事にトラックバックする(FC2ブログユーザー)
| ホーム |